Manual browser: an(4)
|AN(4)||Kernel Interfaces Manual||AN(4)|
NAMEan — Aironet 4500/4800 and Cisco 340/350 series wireless network driver
SYNOPSISan* at pcmcia? function ?
an* at pci? dev ? function ?
an* at isapnp?
DESCRIPTIONThe an driver provides support for Aironet Communications 4500/4800 and Cisco Aironet 340/350 series wireless network adapters. This includes the ISA, PCI and PCMCIA varieties. The 4500 series adapters operate at 1 and 2Mbps while the 4800 series and 340/350 series can operate at 1, 2, 5.5 and 11Mbps. The ISA, PCI and PCMCIA devices are all based on the same core PCMCIA modules and all have the same programming interface, however unlike the Lucent WaveLAN/IEEE cards, the ISA and PCI cards appear to the host as normal ISA and PCI devices and do not require any PCMCIA support.
The PCMCIA Aironet cards require PCMCIA support. ISA cards can either be configured to use ISA Plug and Play or to use a particular I/O address and IRQ by properly setting the DIP switches on the board. (The default switch setting is for plug and play.) The an driver has Plug and Play support and will work in either configuration, however when using a hard-wired I/O address and IRQ, the driver configuration and the NIC's switch settings must agree. PCI cards require no switch settings of any kind and will be automatically probed and attached.
All host/device interaction with the Aironet cards is via programmed I/O. The Aironet devices support 802.11 and 802.3 frames, power management, BSS (infrastructure) and IBSS (ad-hoc) operation modes. The an driver encapsulates all IP and ARP traffic as 802.11 frames, however it can receive either 802.11 or 802.3 frames. Transmit speed is selectable between 1Mbps, 2Mbps, 5.5Mbps, 11Mbps, or “auto” (the NIC automatically chooses the best speed).
By default, the an driver configures the Aironet card to join an access point with an SSID of null string. For ad-hoc mode, in which stations can communicate among each other without the aid of an access point, the driver must be set using ifconfig(8).
HARDWARECards supported by the an driver include:
- Aironet 4500 Series
- Aironet 4800 Series
- Cisco Aironet 340 Series
- Cisco Aironet 350 Series
- an%d: init failed
- The Aironet card failed to come ready after an initialization command was issued.
- an%d: failed to allocate %d bytes on NIC
- The driver was unable to allocate memory for transmit frames in the NIC's on-board RAM.
- an%d: device timeout
- The Aironet card failed to generate an interrupt to acknowledge a transmit command.
HISTORYThe an device driver first appeared in FreeBSD 4.0, and then in NetBSD 1.6.
AUTHORSThe an driver was written by <firstname.lastname@example.org>.
|December 13, 2000||NetBSD 7.0|