Manual browser: cardbus(4)
|CARDBUS(4)||Kernel Interfaces Manual||CARDBUS(4)|
NAMEcardbus, cardslot, cbb — CardBus driver
SYNOPSIScbb* at pci? dev? function ?
cardslot* at cbb?
cardbus* at cardslot?
pcmcia* at cardslot?
XX* at cardbus? function ?
DESCRIPTIONNetBSD provides machine-independent bus support and drivers for CardBus devices.
The cbb device represents the CardBus controller. Each controller has a number of slots, represented by the cardslot devices. A slot can have either a CardBus card or a PCMCIA card, which are attached with the cardbus or pcmcia devices, respectively.
SUPPORTED DEVICESNetBSD includes the following machine-independent CardBus drivers, sorted by function and driver name:
- Atheros 5210/5211/5212 802.11
- ADMtek ADM8211 (802.11)
- Broadcom BCM430x/4318 (802.11)
- 3Com 3c575TX and 3c575BTX
- Intel i8255x
- Ralink Technology RT25x0 (802.11)
- RealTek 8139C+/8169/8169S/8110S
- Realtek 8129/8139
- Realtek 8180L (802.11)
- DECchip 21143
- Modems and serial cards
- AdvanSys 1200[A,B], 9xx[U,UA]
- Adaptec ADP-1480
- Workbit NinjaSCSI-32
- Enhanced Host Controller (2.0)
- Open Host Controller
- Universal Host Controller
- OHCI controller
- SD Host Controller
Disk and tape controllers
- Workbit NinjaATA-32
- Silicon Image SATA-II controllers
DIAGNOSTICScbb devices may not be properly handled by the system BIOS on i386-family systems. If, on an i386-family system, the cbb driver reports
cbb0: NOT USED because of unconfigured interrupt
- options PCI_ADDR_FIXUP
- options PCI_BUS_FIXUP
- options PCI_INTR_FIXUP
- options PCI_INTR_FIXUP_DISABLED
SEE ALSOadv(4), ahc(4), ath(4), atw(4), bwi(4), com(4), ehci(4), ex(4), fwohci(4), fxp(4), njata(4), njs(4), ohci(4), options(4), pci(4), pcmcia(4), ral(4), re(4), rtk(4), rtw(4), sdhc(4), siisata(4), tlp(4), uhci(4)
HISTORYThe cardbus driver appeared in NetBSD 1.5.
Memory space conflictsNetBSD maps memory on Cardbus and PCMCIA cards in order to access the cards (including reading CIS tuples on PCMCIA cards) and access the devices using the RBUS abstraction. When the mapping does not work, PCMCIA cards are typically ignored on insert, and Cardbus cards are recognized but nonfunctional. On i386, the kernel has a heuristic to choose a memory address for mapping, defaulting to 1 GB, but choosing 0.5 GB on machines with less than 192 MB RAM and 2 GB on machines with more than 1 GB of RAM. The intent is to use an address that is larger than available RAM, but low enough to work; some systems seem to have trouble with addresses requiring more than 20 address lines. On i386, the following kernel configuration line disables the heuristics and forces Cardbus memory space to be mapped at 512M; this value makes Cardbus support (including PCMCIA attachment under a cbb) work on some notebook models, including the IBM Thinkpad 600E (2645-4AU) and the Compaq ARMADA M700:
|April 25, 2012||NetBSD 7.0|