Manual browser: cnw(4)
|CNW(4)||Kernel Interfaces Manual||CNW(4)|
NAMEcnw — Netwave AirSurfer wireless network driver
SYNOPSIScnw* at pcmcia? function ?
DESCRIPTIONThe cnw interface provides access to a theoretical 1 Mb/s wireless Ethernet network based on the Netwave AirSurfer Wireless LAN (formerly known as the Xircom Netwave Wireless LAN).
Note that the driver does not support newer devices such as the Netwave AirSurfer “Plus”, or the BayStack 650/660. These devices are supported by the awi(4) driver.
Netwave devices are not compatible with IEEE 802.11 wireless networks. Also note that there are Netwave devices with different wireless frequency, depending on the radio band plan in each country.
The card uses 36K of I/O memory mapped to the card. You may need to increase memory space available to the PCMCIA controller. See pcmcia(4) for details.
In use, the cards appear to achieve up to a 420Kb/s transfer rate, though a transfer rate between 250Kb/s and 350Kb/s is typical.
The card operates in the 2.4GHz frequency range and is subject to interference from microwaves, IEEE 802.11 wireless network devices, as well as earth. For example, it seems that IEEE 802.11 channel 14 conflicts with Netwave (US frequency). They interfere with each other if they are both operated in the same geographic region, causing weird packet loss. You may be able to avoid the interference with IEEE 802.11 devices, by changing the IEEE 802.11 channel.
HARDWARECards supported by the cnw driver include:
- Xircom CreditCard Netwave
- NetWave AirSurfer
- cnw0: can't map memory
- Indicates that the driver was not able to allocate enough PCMCIA bus address space into which to map the device. See pcmcia(4) and increase memory available to the PCMCIA controller.
|January 5, 1997||NetBSD 7.0|