Manual browser: esp(4)
|ESP(4)||Kernel Interfaces Manual||ESP(4)|
NAMEesp — NCR 53C9x, Emulex ESP406, and Qlogic FAS408 SCSI driver
ISA busesp0 at isa? port 0x230 irq ?
PCMCIAesp* at pcmcia? function ?
MCAesp* at mca? slot ?
mac68kesp0 at obio?
esp1 at obio?
macppcesp0 at obio0 flags 0x00ff
sun3xesp0 at obio0 addr 0x66000000 ipl 2 flags 0xff0f
sparcdma0 at obio0 addr 0xfa001000 level 4 (Sun 4/300)
esp0 at obio0 addr 0xfa000000 level 4 (Sun 4/300)
dma0 at sbus0 slot ? offset ? (sun4c and sun4m)
esp0 at sbus0 slot ? offset ? (sun4c)
esp0 at dma0 (sun4m)
dma* at sbus? slot ? offset ? (Sbus)
esp* at sbus? slot ? offset ? (SBus, older PROMs)
esp* at dma? (SBus)
scsibus* at esp?
DESCRIPTIONThe esp driver provides support for the NCR 53C90, 53C94 and 53C96; Emulex ESP100, ESP100A, ESP200 and ESP406; and Qlogic FAS216 and FAS408 SCSI controller chips found in a wide variety of systems and peripheral boards. This includes the Qlogic ISA and VLB SCSI host adapters, and the Sun Fast SCSI buffered Ethernet for Sbus (FSBE/S, X1053A, Sun part # 501-2015).
For Qlogic PCI SCSI host adapters, use the isp(4) device.
CONFIGURATIONThe esp driver supports the following flags for use in config(1) files:
- bits 0-7:
- disable disconnect/reselect for the corresponding SCSI target
- bits 8-15:
- disable synchronous negotiation for the corresponding SCSI target
- bits 16-23:
- disable tagged queuing for the corresponding SCSI target
“Target” is synonymous with SCSI ID number.
Note that SCSI tape drives should be allowed to perform disconnect/reselect or performance will suffer.
|December 3, 2001||NetBSD 7.0|