Manual browser: icmp(4)
|ICMP(4)||Kernel Interfaces Manual||ICMP(4)|
NAMEicmp — Internet Control Message Protocol
DESCRIPTIONICMP is the error and control message protocol used by IP and the Internet protocol family. It may be accessed through a “raw socket” for network monitoring and diagnostic functions. The proto parameter to the socket call to create an ICMP socket is obtained from getprotobyname(3). ICMP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the read(2) or recv(2) and write(2) or send(2) system calls may be used).
Outgoing packets automatically have an IP header prepended to them (based on the destination address). Incoming packets are received with the IP header and options intact.
DIAGNOSTICSA socket operation may fail with one of the following errors returned:
- when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is already connected;
- when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected;
- when the system runs out of memory for an internal data structure;
- when an attempt is made to create a socket with a network address for which no network interface exists.
SEE ALSOrecv(2), send(2), inet(4), intro(4), ip(4)
Internet Control Message Protocol, RFC, 792, September 1981.
Requirements for Internet Hosts -- Communication Layers, RFC, 1122, October 1989.
HISTORYThe icmp protocol appeared in 4.3BSD.
|June 5, 1993||NetBSD 7.0|