Manual browser: mfi(4)
|MFI(4)||Kernel Interfaces Manual||MFI(4)|
NAMEmfi — LSI Logic & Dell MegaRAID SAS RAID controller
SYNOPSISmfi* at pci? dev ? function ?
DESCRIPTIONThe mfi driver provides support for the MegaRAID SAS family of RAID controllers, including:
- Dell PERC 5/e, PERC 5/i, PERC 6/e, PERC 6/i
- Intel RAID Controller SRCSAS18E, SRCSAS144E
- LSI Logic MegaRAID SAS 8208ELP, MegaRAID SAS 8208XLP, MegaRAID SAS 8300XLP, MegaRAID SAS 8308ELP, MegaRAID SAS 8344ELP, MegaRAID SAS 8408E, MegaRAID SAS 8480E, MegaRAID SAS 8708ELP, MegaRAID SAS 8888ELP, MegaRAID SAS 8880EM2, MegaRAID SAS 9260-8i
- IBM ServeRAID M1015, ServeRAID M5014
These controllers support RAID 0, RAID 1, RAID 5, RAID 6, RAID 10, RAID 50 and RAID 60 using either SAS or SATA II drives.
Although the controllers are actual RAID controllers, the driver makes them look just like SCSI controllers. All RAID configuration is done through the controllers' BIOSes.
EVENTSThe mfi driver is able to send events to powerd(8) if a logical drive in the controller is not online. The state-changed event will be sent to the /etc/powerd/scripts/sensor_drive script when such condition happens.
HISTORYThe mfi driver first appeared in NetBSD 4.0.
|March 22, 2012||NetBSD 7.0|