Manual browser: mk48txx(4)
MK48TXX(4) | Kernel Interfaces Manual | MK48TXX(4) |
NAME
mk48txx — Mostek time-of-day clock driverSYNOPSIS
#include <dev/ic/mk48txxreg.h>#include <dev/ic/mk48txxvar.h>
define mk48txx
file dev/ic/mk48txx.c mk48txx
DESCRIPTION
The mk48txx driver provides access to several models of Mostek time-of-day clock chips. Access methods to retrieve and set date and time are provided through the TODR interface defined in todr(9).To tie an instance of this device to the system, use the mk48txx_attach() function and the mk48txx_softc structure defined as follows:
void mk48txx_attach(struct mk48txx_softc *)
typedef uint8_t (*mk48txx_nvrd_t)(struct mk48txx_softc *, int off); typedef void (*mk48txx_nvwr_t)(struct mk48txx_softc *, int off, uint8_t datum);
struct mk48txx_softc { struct device sc_dev; bus_space_tag_t sc_bst; bus_space_handle_t sc_bsh; struct todr_chip_handle sc_handle; const char *sc_model; bus_size_t sc_nvramsz; bus_size_t sc_clkoffset; u_int sc_year0; u_int sc_flag; mk48txx_nvrd_t sc_nvrd; mk48txx_nvwr_t sc_nvwr; };
- sc_bst
- sc_bsh
- Specify bus space access to the chip's non-volatile memory (including the clock registers).
- sc_handle
- TODR handle passed to the todr_attach() function to register todr(9) interface.
- sc_model
- The chip model which this instance should serve. Must be one of “mk48t02”, “mk48t08”, “mk48t18”, or “mk48t59”.
- sc_nvramsz
- Size of non-volatile RAM in the Mostek chip. This value is set by mk48txx_attach().
- sc_clkoffset
- Offset into the control registers of the Mostek chip. This value is set by mk48txx_attach().
- sc_year0
- The actual year represented by the clock's ‘year’ counter. This is generally dependent on the system configuration in which the clock device is mounted. For instance, on Sun Microsystems machines the convention is to have clock's two-digit year represent the year 1968.
- sc_flag
- This flag is used to specify machine-dependent features.
- sc_nvread
- sc_nvwrite
-
Specify alternate access methods for reading resp. writing clock device registers. The default, when NULL is passed as an access method, is to access the chip memory (and clock registers) as if they were direct-mapped with using the specified bus space.
Otherwise, the driver will call the respective function to perform the access, passing it the specified bus space and the offset off of the chip memory (or clock register) location to be read from or written to, respectively.
Note that if the resulting date retrieved with the todr_gettime() method is earlier that January 1, 1970, the driver will assume that the chip's year counter actually represents a year in the 21st century. This behaviour can be overridden by setting the MK48TXX_NO_CENT_ADJUST flag in sc_flag.
HARDWARE
The following models are supported:
- Mostek MK48T02
- Mostek MK48T08
- Mostek MK48T18
- Mostek MK48T59
HISTORY
The mk48txx driver first appeared in NetBSD 1.5.AUTHORS
The mk48txx driver was written by <pk@NetBSD.org>.October 1, 2006 | NetBSD 7.0 |