Manual browser: uhidev(4)
|UHIDEV(4)||Kernel Interfaces Manual||UHIDEV(4)|
NAMEuhidev — USB Human Interface Device support
SYNOPSISuhidev* at uhub?
ucycom* at uhidev? reportid ?
uhid* at uhidev? reportid ?
ukbd* at uhidev? reportid ?
ums* at uhidev? reportid ?
DESCRIPTIONThe uhidev driver handles all Human Interface Devices. Each HID device can have several components, e.g., a keyboard and a mouse. These components use different report identifiers (a byte) to distinguish which one data is coming from. The uhidev driver has other drivers attached that handle particular kinds of devices and uhidev only dispatches data to them based on the report id.
HISTORYThe uhidev driver appeared in NetBSD 1.6.
|July 30, 2005||NetBSD 7.0|