Manual browser: userconf(4)
|USERCONF(4)||Kernel Interfaces Manual||USERCONF(4)|
NAMEuserconf — in-kernel device configuration manager
DESCRIPTIONuserconf is the in-kernel device configuration manager. It is used to alter the kernel autoconfiguration framework at runtime. userconf is activated from the boot loader by passing the -c option to the kernel.
COMMAND SYNTAXThe general command syntax is:
userconf has a more(1)-like functionality; if a number of lines in a command's output exceeds the number defined in the lines variable, then userconf displays “-- more --” and waits for a response, which may be one of:
- one more line.
- one more page.
- abort the current command, and return to the command input mode.
COMMANDSuserconf supports the following commands:
- lines count
- Specify the number of lines before more.
- base 8 | 10 | 16
- Base for displaying large numbers.
- change devno | dev
- Change devices.
- disable devno | dev
- Disable devices.
- enable devno | dev
- Enable devices.
- A synonym for quit.
- find devno | dev
- Find devices.
- Display online help.
- List current configuration.
- Leave userconf.
- A synonym for help.
HISTORYThe userconf framework first appeared in OpenBSD 2.0, and was then integrated into NetBSD 1.6.
AUTHORSThe userconf framework was written by <firstname.lastname@example.org>.
|July 1, 2001||NetBSD 7.0|