Manual browser: ccd.conf(5)
|CCD.CONF(5)||File Formats Manual||CCD.CONF(5)|
NAMEccd.conf — concatenated disk driver configuration file
DESCRIPTIONThe ccd.conf file defines the configuration of concatenated disk devices, or ccds. It is used by ccdconfig(8) when invoked with the -C option and at system boot time. For more information about the concatenated disk driver, see ccd(4).
Each line of the configuration file contains arguments as per the -c argument to ccdconfig(8):
- The name of the ccd.
- The interleave, expressed in units of DEV_BSIZE.
- The flags for the device, which may be represented as a decimal number, a hexadecimal number, a comma-separated list of strings, or the word “none”.
- dev [...]
- The component partitions to be concatenated, which should be of type FS_CCD.
A ‘#’ is a comment, and everything to end of line is ignored. A ‘\’ at the end of a line indicates that the next line should be concatenated with the current. A ‘\’ preceding any character (other than the end of line) prevents that character's special meaning from taking effect.
EXAMPLESAn example /etc/ccd.conf:
# # /etc/ccd.conf # Configuration file for concatenated disk devices # # ccd ileave flags component devices ccd0 16 none /dev/sd2e /dev/sd3e
HISTORYThe ccd.conf configuration file first appeared in NetBSD 1.1.
|June 11, 2002||NetBSD 7.0|