Manual browser: ethers(5)
|ETHERS(5)||File Formats Manual||ETHERS(5)|
NAMEethers — Ethernet host name data base
DESCRIPTIONThe ethers file maps Ethernet MAC addresses to host names. Lines consist of an address and a host name, separated by any number of blanks and/or tab characters. A ‘#’ character indicates the beginning of a comment; characters up to the end of the line are not interpreted by routines which search the file.
Each line in ethers has the format:
The traditional use of ethers involved using hostnames for the second argument. This may not be suitable for machines that don't have a common MAC address for all interfaces (i.e., just about every non Sun machine). There should be no problem in using an IP address as the second field if you wish to differentiate between different interfaces on a system.
- The ethers file resides in /etc.
HISTORYThe ethers file format was adopted from SunOS and appeared in NetBSD 1.0.
BUGSA name server should be used instead of a static file.
|November 7, 2000||NetBSD 7.0|