Manual browser: services(5)
|SERVICES(5)||File Formats Manual||SERVICES(5)|
NAMEservices — service name data base
DESCRIPTIONThe services file contains information regarding the known services available in the DARPA Internet. For each service a single line should be present with the following information:
official service name port number protocol name aliases
Items are separated by any number of blanks and/or tab characters. The port number and protocol name are considered a single item; a slash (“/”) is used to separate the port and protocol (e.g. “512/tcp”). A hash (“#”) indicates the beginning of a comment; subsequent characters up to the end of the line are not interpreted by the routines which search the file.
Service names may contain any printable character other than a field delimiter, newline, or comment character.
The database in /var/db/services.db needs to be updated with services_mkdb(8) after changes to the services file have been applied.
- The services file resides in /etc.
HISTORYThe services file format appeared in 4.2BSD.
BUGSA name server should be used instead of a static file.
|June 19, 2007||NetBSD 7.0|