Manual browser: atrun(8)
|ATRUN(8)||System Manager's Manual||ATRUN(8)|
NAMEatrun — run jobs queued for later execution
|atrun||[-l load_avg] [-d]|
DESCRIPTIONatrun runs jobs queued by at(1). Root's crontab(5) must contain the line:
*/10 * * * * /usr/libexec/atrun
so that atrun gets called every ten minutes.
At every invocation, every job in lowercase queues whose starting time has passed is started. A maximum of one batch job (denoted by uppercase queues) is started each time atrun is invoked.
- -l load_avg
- Specifies a limiting load factor, over which batch jobs should not be run, instead of the compiled-in value of 1.5.
- Debug; print error messages to standard error instead of using syslog(3).
WARNINGSFor atrun to work, a cron(8) daemon needs to be running.
- Directory containing output spool files
- Directory containing job files
BUGSThe functionality of atrun should be merged into cron(8).
|April 12, 1995||NetBSD 7.0|