Manual browser: dbsym(8)
|DBSYM(8)||System Manager's Manual||DBSYM(8)|
NAMEdbsym — copy kernel symbol table into db_symtab space
|dbsym||[-pv] [-b bfdname] kernel|
DESCRIPTIONdbsym is used to copy the symbol table in a newly linked kernel into the db_symtab array (in the data section) so that the ddb(4) kernel debugger can find the symbols. This program is only used on systems for which the boot program does not load the symbol table into memory with the kernel. The space for these symbols is reserved in the data segment using a config option like:
The size of the db_symtab array (the value of SYMTAB_SPACE) must be at least as large as the kernel symbol table. If insufficient space is reserved, dbsym will refuse to copy the symbol table.
To recognize kernel executable format, the -b flag specifies BFD name of kernel.
If the -p flag is given, dbsym will report the size of the kernel symbol table and the size of the db_symtab space. Two values are printed out in a line separated by a space.
If the -v flag is given, dbsym will print out status information as it is copying the symbol table.
Note that debugging symbols are not useful to the ddb(4) kernel debugger, so to minimize the size of the kernel, one should either compile the kernel without debugging symbols (no -g flag) or use the strip(1) command to strip debugging symbols from the kernel before dbsym is used to copy the symbol table. The command
will strip out debugging symbols.
strip -d netbsd
|March 19, 2012||NetBSD 7.0|