Manual browser: irda(8)
|IRDAATTACH(8)||System Manager's Manual||IRDAATTACH(8)|
NAMEirdaattach — attach serial lines to IrDA frame driver
|irdaattach||[-d dongle] [-fHhlmnp] ttyname|
DESCRIPTIONirdaattach is used to assign a tty line to an IrDA frame level driver. The following operands are supported by irdaattach:
- -d dongle
Sets the dongle type. The following dongles are supported:
- No dongle
- Tekram IR-210B
- Extended Systems JetEye
- ACTiSYS IR-220L
- ACTiSYS IR-220L+
- Parallax LiteLink
- Greenwich GIrBIL
The default is none.
- Print the name of the IrDA frame device that should be used to access the frames.
- Turn on DTR/CTS flow control. By default, no flow control is done.
- Turn on RTS/CTS flow control. By default, no flow control is done.
- Turn on the CLOCAL flag, making it possible to run SLIP on a cable without modem control signals (e.g. DTR, DSR, DCD).
- Maintain modem control signals after closing the line. Specifically, this disables HUPCL.
- Do not detach from invoking tty.
- Print process id to file.
Specifies the name of the tty device. Ttyname should be a string of the form ‘
ttyXX’, or ‘
Only the super-user may attach a network interface.
The frame driver is detached by killing the irdaattach process.
irdaattach tty00 ircomm -Y -d `irdaattach -p -f /dev/tty02`
DIAGNOSTICSMessages indicating that the specified interface does not exist, the requested address is unknown, or that the user is not privileged but tried to alter an interface's configuration.
HISTORYThe irdaattach command appeared in NetBSD 1.6.
|December 4, 2001||NetBSD 7.0|