Manual browser: lastlogin(8)
|LASTLOGIN(8)||System Manager's Manual||LASTLOGIN(8)|
NAMElastlogin — indicate last login time of users
|lastlogin||[-nrt] [-f filename] [-H hostsize] [-L linesize] [-N namesize] [user ...]|
DESCRIPTIONlastlogin will list the last login session of specified users, or for all users by default. Each line of output contains the user name, the tty from which the session was conducted, any hostname, and the start time for the session.
If multiple users are given, the session information for each user is printed in the order given on the command line. Otherwise, information for all users is printed, sorted by uid.
lastlogin differs from last(1) in that it only prints information regarding the very last login session. The last login database is never turned over or deleted in standard usage.
The following options are available:
- -f filename
- Process input from filename. If the file ends with an “x”, then it is assumed that it is a lastlogx(5) file, else it is assumed to be a lastlog(5) file.
- -H hostlen
- Set the field width for host output to hostlen characters.
- -L linelen
- Set the field width for line output to linelen characters.
- -N namelen
- Set the field width for name output to namelen characters.
- Attempt to print numeric host addresses. This option is only supported with lastlogx(5) format files.
- Reverse the order of the sort.
- Sort by last login time (most recent first.)
- default last login database
- compatibility last login database
EXAMPLESlastlogin looks by default to the /var/log/lastlogx database, where some old programs that are not utmpx(5) aware might only write to /var/log/lastlog. To look at the old database one can use:
lastlogin -f /var/log/lastlog
AUTHORSwrote this program in January 1996 and contributed it to the NetBSD project.
|March 4, 2005||NetBSD 7.0|