Manual browser: mount_kernfs(8)
|MOUNT_KERNFS(8)||System Manager's Manual||MOUNT_KERNFS(8)|
NAMEmount_kernfs — mount the /kern file system
|mount_kernfs||[-o options] /kern mount_point|
DESCRIPTIONThe mount_kernfs command attaches an instance of the kernel parameter namespace to the global filesystem namespace. The conventional mount point is /kern. The directory specified by mount_point is converted to an absolute path before use. This command is normally executed by mount(8) at boot time.
The filesystem includes several regular files which can be read, some of which can also be written. The contents of the files is in a machine-independent format, either a string, or an integer in decimal ASCII. Where numbers are returned, a trailing newline character is also added.
The options are as follows:
- Options are specified with a -o flag followed by a comma separated string of options. See the mount(8) man page for possible options and their meanings.
- the time at which the system was last booted (decimal ASCII).
- kernel copyright message.
- the hostname, with a trailing newline. The hostname can be changed by writing to this file. A trailing newline will be stripped from the hostname being written.
- the frequency of the system clock (decimal ASCII).
- the 1, 5 and 15 minute load average in kernel fixed-point format. The final integer is the fix-point scaling factor. All numbers are in decimal ASCII.
- the kernel message buffer, also read by syslogd(8), through the log device, and by dmesg(8).
- the machine pagesize (decimal ASCII).
- the number of pages of physical memory in the machine (decimal ASCII).
- the root device.
- the raw root device.
- the second and microsecond value of the system clock. Both numbers are in decimal ASCII.
- the kernel version string. The head line for /etc/motd can be generated by running: “sed 1q /kern/version”
HISTORYThe mount_kernfs utility first appeared in 4.4BSD.
BUGSThis filesystem may not be NFS-exported.
|March 22, 2012||NetBSD 7.0|