Manual browser: mount_overlay(8)
|MOUNT_OVERLAY(8)||System Manager's Manual||MOUNT_OVERLAY(8)|
NAMEmount_overlay — mount an overlay filesystem; demonstrate the use of an overlay file system layer
|mount_overlay||[-o options] /overlay mount-point|
DESCRIPTIONThe mount_overlay command creates an overlay layer, interposing the overlay filesystem between the over-mounted file store and future pathname lookups.
A different device number for the virtual copy is returned by stat(2), but in other respects it is indistinguishable from the original.
The mount_overlay filesystem differs from the null filesystem in that the mount_overlay filesystem does not replicate the sub-tree, it places itself between the sub-tree and all future access.
The overlay layer has two purposes. First, it serves as a demonstration of layering by providing a layer which does nothing other than insert itself over the over-mounted file system. Second, the overlay layer can serve as a prototype layer. Since it provides all necessary layer framework, new file system layers which need to block access to the overlayed file system can be created very easily by starting with an overlay layer.
The internal operation of the overlay layer is identical to that of the null layer. See its documentation for details.
SEE ALSOmount(8), mount_null(8)
UCLA Technical Report CSD-910056, Stackable Layers: an Architecture for File System Development.
HISTORYThe mount_overlay utility first appeared in NetBSD 1.5.
|January 18, 2000||NetBSD 7.0|