Manual browser: paxctl(8)
|PAXCTL(8)||System Manager's Manual||PAXCTL(8)|
NAMEpaxctl — list and modify PaX flags associated with an ELF program
|paxctl||flags program ...|
DESCRIPTIONThe paxctl utility is used to list and manipulate PaX flags associated with an ELF program. The PaX flags signify to the loader the privilege protections to be applied to mapped memory pages, and fuller explanations of the specific protections can be found in the security(7) manpage.
Each flag can be prefixed either with a “+” or a “-” sign to add or remove the flag, respectively.
The following flags are available:
- Explicitly disable PaX ASLR (Address Space Layout Randomization) for program.
- Explicitly enable PaX ASLR for program.
- Explicitly disable PaX Segvguard for program.
- Explicitly enable PaX Segvguard for program.
- Explicitly disable PaX MPROTECT (mprotect(2) restrictions) for program.
- Explicitly enable PaX MPROTECT (mprotect(2) restrictions) for program.
To view existing flags on a file, execute paxctl without any flags.
HISTORYThe paxctl utility first appeared in NetBSD 4.0.
The paxctl utility is modeled after a tool of the same name available for Linux from the PaX project.
BUGSThe paxctl utility currently uses elf(5) “note” sections to mark executables as PaX Segvguard enabled. This will be done using fileassoc(9) in the future so that we can control who does the marking and not altering the binary file signature.
|September 17, 2009||NetBSD 7.0|