Manual browser: rump_cd9660(8)
|RUMP_CD9660(8)||System Manager's Manual||RUMP_CD9660(8)|
NAMErump_cd9660 — mount a cd9660 image with a userspace server
|rump_cd9660||[options] image mountpoint|
DESCRIPTIONNOTE! This manual page describes features specific to the rump(3) file server. Please see mount_cd9660(8) for a full description of the available command line options.
The rump_cd9660 utility can be used to mount cd9660 file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_cd9660(8), rump_cd9660 does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code.
rump_cd9660 does not require using vnconfig(8) for mounts from regular files and the file path can be passed directly as the image parameter. In fact, the use of vnconfig(8) is discouraged, since it is unable to properly deal with images on sparse files.
In case the image contains multiple partitions, the desired partition must be indicated by appending the token “%DISKLABEL:p%” to the image path. The letter “p” specifies the partition as obtained via disklabel(8). For example, to mount partition “e” from image /tmp/wd0.img, use “/tmp/wd0.img%DISKLABEL:e%”.
It is recommended that untrusted file system images be mounted with rump_cd9660 instead of mount_cd9660(8). Corrupt file system images commonly cause the file system to crash the entire kernel, but with rump_cd9660 only the userspace server process will dump core.
HISTORYThe rump_cd9660 utility first appeared in NetBSD 5.0.
|November 21, 2010||NetBSD 7.0|