Manual browser: rump_smbfs(8)
|RUMP_SMBFS(8)||System Manager's Manual||RUMP_SMBFS(8)|
NAMErump_smbfs — mount a smbfs share with a userspace server
|rump_smbfs||[options] share mountpoint|
DESCRIPTIONNOTE! This manual page describes features specific to the rump(3) file server. Please see mount_smbfs(8) for a full description of the available command line options.
The rump_smbfs utility can be used to mount smbfs file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_smbfs(8), rump_smbfs does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code.
Even though the rump_smbfs file system client runs within a virtual rump kernel in userspace, it uses host network services (by means of “rump sockin”). This means that regardless of whether using rump_smbfs or mount_smbfs(8), the same network configurations will be used. Currently, “sockin” supports IPv4.
HISTORYThe rump_smbfs utility first appeared in NetBSD 6.0.
|November 21, 2010||NetBSD 7.0|