Manual browser: rump_sysvbfs(8)
|RUMP_SYSVBFS(8)||System Manager's Manual||RUMP_SYSVBFS(8)|
NAMErump_sysvbfs — mount a sysvbfs image with a userspace server
|rump_sysvbfs||[options] image mountpoint|
DESCRIPTIONNOTE! This manual page describes features specific to the rump(3) file server. Please see mount_sysvbfs(8) for a full description of the available command line options.
The rump_sysvbfs utility can be used to mount sysvbfs file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_sysvbfs(8), rump_sysvbfs does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code.
rump_sysvbfs does not require using vnconfig(8) for mounts from regular files and the file path can be passed directly as the image parameter. In fact, the use of vnconfig(8) is discouraged, since it is unable to properly deal with images on sparse files.
In case the image contains multiple partitions, the desired partition must be indicated by appending the token “%DISKLABEL:p%” to the image path. The letter “p” specifies the partition as obtained via disklabel(8). For example, to mount partition “e” from image /tmp/wd0.img, use “/tmp/wd0.img%DISKLABEL:e%”.
It is recommended that untrusted file system images be mounted with rump_sysvbfs instead of mount_sysvbfs(8). Corrupt file system images commonly cause the file system to crash the entire kernel, but with rump_sysvbfs only the userspace server process will dump core.
HISTORYThe rump_sysvbfs utility first appeared in NetBSD 5.0.
|November 21, 2010||NetBSD 7.0|