Manual browser: disklabel(5)

Section:
Page:
DISKLABEL(5) File Formats Manual DISKLABEL(5)

NAME

disklabeldisk pack label

SYNOPSIS

#include <sys/disklabel.h>

DESCRIPTION

Each disk or disk pack on a system may contain a disk label which provides detailed information about the geometry of the disk and the partitions into which the disk is divided. It should be initialized when the disk is formatted, and may be changed later with the disklabel(8) program. This information is used by the system disk driver and by the bootstrap program to determine how to program the drive and where to find the file systems on the disk partitions. Additional information is used by the file system in order to use the disk most efficiently and to locate important file system information. The description of each partition contains an identifier for the partition type (standard file system, swap area, etc.). The file system updates the in-core copy of the label if it contains incomplete information about the file system.

The label is located in the sector number returned by the getlabelsector(3) function, usually sector 0 where it may be found without any information about the disk geometry. It is at an offset (specified by the getlabeloffset(3) function) from the beginning of the sector, to allow room for the initial bootstrap. The disk sector containing the label is normally made read-only so that it is not accidentally overwritten by pack-to-pack copies or swap operations; the DIOCWLABEL ioctl(2), which is done as needed by the disklabel(8) program.

A copy of the in-core label for a disk can be obtained with the DIOCGDINFO ioctl(2); this works with a file descriptor for a block or character (``raw'') device for any partition of the disk. The in-core copy of the label is set by the DIOCSDINFO ioctl(2). The offset of a partition cannot generally be changed while it is open, nor can it be made smaller while it is open. One exception is that any change is allowed if no label was found on the disk, and the driver was able to construct only a skeletal label without partition information. Finally, the DIOCWDINFO ioctl(2) operation sets the in-core label and then updates the on-disk label; there must be an existing label on the disk for this operation to succeed. Thus, the initial label for a disk or disk pack must be installed by writing to the raw disk. All of these operations are normally done using disklabel(8).

The format of the disk label, as specified in sys/disklabel.h, is

/* 
 * Disk description table, see disktab(5) 
 */ 
#define	_PATH_DISKTAB	"/etc/disktab" 
 
/* 
 * Each disk has a label which includes information about the hardware 
 * disk geometry, file system partitions, and drive specific information. 
 * The location of the label, as well as the number of partitions the 
 * label can describe and the number of the "whole disk" (raw) 
 * partition are machine dependent. 
 */ 
#include <machine/disklabel.h> 
 
/* 
 * The absolute maximum number of disk partitions allowed. 
 * This is the maximum value of MAXPARTITIONS for which 'struct disklabel' 
 * is ≤ DEV_BSIZE bytes long.  If MAXPARTITIONS is greater than this, beware. 
 */ 
#define MAXMAXPARTITIONS	22 
#if MAXPARTITIONS > MAXMAXPARTITIONS 
#warning beware: MAXPARTITIONS bigger than MAXMAXPARTITIONS 
#endif 
 
 
#define DISKMAGIC	((u_int32_t)0x82564557) /* The disk magic number */ 
 
#ifndef _LOCORE 
struct disklabel { 
	u_int32_t d_magic;		/* the magic number */ 
	u_int16_t d_type;		/* drive type */ 
	u_int16_t d_subtype;		/* controller/d_type specific */ 
	char	  d_typename[16];	/* type name, e.g. "eagle" */ 
 
	/* 
	 * d_packname contains the pack identifier and is returned when 
	 * the disklabel is read off the disk or in-core copy. 
	 * d_boot0 and d_boot1 are the (optional) names of the 
	 * primary (block 0) and secondary (block 1-15) bootstraps 
	 * as found in /usr/mdec.  These are returned when using 
	 * getdiskbyname(3) to retrieve the values from /etc/disktab. 
	 */ 
	union { 
		char	un_d_packname[16];	/* pack identifier */ 
		struct { 
			char *un_d_boot0;	/* primary bootstrap name */ 
			char *un_d_boot1;	/* secondary bootstrap name */ 
		} un_b; 
	} d_un; 
#define d_packname	d_un.un_d_packname 
#define d_boot0		d_un.un_b.un_d_boot0 
#define d_boot1		d_un.un_b.un_d_boot1 
 
			/* disk geometry: */ 
	u_int32_t d_secsize;		/* # of bytes per sector */ 
	u_int32_t d_nsectors;		/* # of data sectors per track */ 
	u_int32_t d_ntracks;		/* # of tracks per cylinder */ 
	u_int32_t d_ncylinders;		/* # of data cylinders per unit */ 
	u_int32_t d_secpercyl;		/* # of data sectors per cylinder */ 
	u_int32_t d_secperunit;		/* # of data sectors per unit */ 
 
	/* 
	 * Spares (bad sector replacements) below are not counted in 
	 * d_nsectors or d_secpercyl.  Spare sectors are assumed to 
	 * be physical sectors which occupy space at the end of each 
	 * track and/or cylinder. 
	 */ 
	u_int16_t d_sparespertrack;	/* # of spare sectors per track */ 
	u_int16_t d_sparespercyl;	/* # of spare sectors per cylinder */ 
	/* 
	 * Alternative cylinders include maintenance, replacement, 
	 * configuration description areas, etc. 
	 */ 
	u_int32_t d_acylinders;		/* # of alt. cylinders per unit */ 
 
			/* hardware characteristics: */ 
	/* 
	 * d_interleave, d_trackskew and d_cylskew describe perturbations 
	 * in the media format used to compensate for a slow controller. 
	 * Interleave is physical sector interleave, set up by the 
	 * formatter or controller when formatting.  When interleaving is 
	 * in use, logically adjacent sectors are not physically 
	 * contiguous, but instead are separated by some number of 
	 * sectors.  It is specified as the ratio of physical sectors 
	 * traversed per logical sector.  Thus an interleave of 1:1 
	 * implies contiguous layout, while 2:1 implies that logical 
	 * sector 0 is separated by one sector from logical sector 1. 
	 * d_trackskew is the offset of sector 0 on track N relative to 
	 * sector 0 on track N-1 on the same cylinder.  Finally, d_cylskew 
	 * is the offset of sector 0 on cylinder N relative to sector 0 
	 * on cylinder N-1. 
	 */ 
	u_int16_t d_rpm;		/* rotational speed */ 
	u_int16_t d_interleave;		/* hardware sector interleave */ 
	u_int16_t d_trackskew;		/* sector 0 skew, per track */ 
	u_int16_t d_cylskew;		/* sector 0 skew, per cylinder */ 
	u_int32_t d_headswitch;		/* head switch time, usec */ 
	u_int32_t d_trkseek;		/* track-to-track seek, usec */ 
	u_int32_t d_flags;		/* generic flags */ 
#define NDDATA 5 
	u_int32_t d_drivedata[NDDATA];	/* drive-type specific information */ 
#define NSPARE 5 
	u_int32_t d_spare[NSPARE];	/* reserved for future use */ 
	u_int32_t d_magic2;		/* the magic number (again) */ 
	u_int16_t d_checksum;		/* xor of data incl. partitions */ 
 
			/* file system and partition information: */ 
	u_int16_t d_npartitions;	/* number of partitions in following */ 
	u_int32_t d_bbsize;		/* size of boot area at sn0, bytes */ 
	u_int32_t d_sbsize;		/* max size of fs superblock, bytes */ 
	struct	partition {		/* the partition table */ 
		u_int32_t p_size;	/* number of sectors in partition */ 
		u_int32_t p_offset;	/* starting sector */ 
		u_int32_t p_fsize;	/* file system basic fragment size */ 
		u_int8_t p_fstype;	/* file system type, see below */ 
		u_int8_t p_frag;	/* file system fragments per block */ 
		union { 
			u_int16_t cpg;	/* UFS: FS cylinders per group */ 
			u_int16_t sgs;	/* LFS: FS segment shift */ 
		} __partition_u1; 
#define	p_cpg	__partition_u1.cpg 
#define	p_sgs	__partition_u1.sgs 
	} d_partitions[MAXPARTITIONS];	/* actually may be more */ 
}; 
#else /* _LOCORE */ 
	/* 
	 * offsets for asm boot files. 
	 */ 
	.set	d_secsize,40 
	.set	d_nsectors,44 
	.set	d_ntracks,48 
	.set	d_ncylinders,52 
	.set	d_secpercyl,56 
	.set	d_secperunit,60 
	.set	d_end_,276		/* size of disk label */ 
#endif /* _LOCORE */ 
 
/* d_type values: */ 
#define	DTYPE_SMD	1	/* SMD, XSMD; VAX hp/up */ 
#define	DTYPE_MSCP	2	/* MSCP */ 
#define	DTYPE_DEC	3	/* other DEC (rk, rl) */ 
#define	DTYPE_SCSI	4	/* SCSI */ 
#define	DTYPE_ESDI	5	/* ESDI interface */ 
#define	DTYPE_ST506	6	/* ST506 etc. */ 
#define	DTYPE_HPIB	7	/* CS/80 on HP-IB */ 
#define	DTYPE_HPFL	8	/* HP Fiber-link */ 
#define	DTYPE_FLOPPY	10	/* floppy */ 
#define DTYPE_CCD	11	/* concatenated disk device */ 
#define DTYPE_VND	12	/* vnode pseudo-disk */ 
#define DTYPE_ATAPI	13	/* ATAPI */ 
#define DTYPE_RAID	14	/* RAIDframe */ 
#define DTYPE_LD	15	/* logical disk */ 
#define DTYPE_JFS2	16	/* IBM JFS2 */ 
#define DTYPE_CGD	17	/* cryptographic pseudo-disk */ 
#define DTYPE_VINUM	18	/* vinum volume obsolete */ 
#define DTYPE_FLASH	19	/* flash memory device */ 
 
#ifdef DKTYPENAMES 
static const char *const dktypenames[] = { 
	"unknown", 
	"SMD", 
	"MSCP", 
	"old DEC", 
	"SCSI", 
	"ESDI", 
	"ST506", 
	"HP-IB", 
	"HP-FL", 
	"type 9", 
	"floppy", 
	"ccd", 
	"vnd", 
	"ATAPI", 
	"RAID", 
	"ld", 
	"jfs", 
	"cgd", 
	"obsolete vinum", 
	"flash", 
	NULL 
}; 
#define DKMAXTYPES	(sizeof(dktypenames) / sizeof(dktypenames[0]) - 1) 
#endif 
 
/* 
 * Filesystem type and version. 
 * Used to interpret other file system-specific 
 * per-partition information. 
 */ 
#define	FS_UNUSED	0	/* unused */ 
#define	FS_SWAP		1	/* swap */ 
#define	FS_V6		2	/* Sixth Edition */ 
#define	FS_V7		3	/* Seventh Edition */ 
#define	FS_SYSV		4	/* System V */ 
#define	FS_V71K		5	/* V7 with 1K blocks (4.1, 2.9) */ 
#define	FS_V8		6	/* Eighth Edition, 4K blocks */ 
#define	FS_BSDFFS	7	/* 4.2BSD fast file system */ 
#define	FS_MSDOS	8	/* MSDOS file system */ 
#define	FS_BSDLFS	9	/* 4.4BSD log-structured file system */ 
#define	FS_OTHER	10	/* in use, but unknown/unsupported */ 
#define	FS_HPFS		11	/* OS/2 high-performance file system */ 
#define	FS_ISO9660	12	/* ISO 9660, normally CD-ROM */ 
#define	FS_BOOT		13	/* partition contains bootstrap */ 
#define	FS_ADOS		14	/* AmigaDOS fast file system */ 
#define	FS_HFS		15	/* Macintosh HFS */ 
#define	FS_FILECORE	16	/* Acorn Filecore Filing System */ 
#define	FS_EX2FS	17	/* Linux Extended 2 file system */ 
#define	FS_NTFS		18	/* Windows/NT file system */ 
#define	FS_RAID		19	/* RAIDframe component */ 
#define	FS_CCD		20	/* concatenated disk component */ 
#define	FS_JFS2		21	/* IBM JFS2 */ 
#define	FS_APPLEUFS	22	/* Apple UFS */ 
#define	FS_VINUM	23	/* Vinum */ 
 
#ifdef	FSTYPENAMES 
static const char *const fstypenames[] = { 
	"unused", 
	"swap", 
	"Version 6", 
	"Version 7", 
	"System V", 
	"4.1BSD", 
	"Eighth Edition", 
	"4.2BSD", 
	"MSDOS", 
	"4.4LFS", 
	"unknown", 
	"HPFS", 
	"ISO9660", 
	"boot", 
	"ADOS", 
	"HFS", 
	"FILECORE", 
	"Linux Ext2", 
	"NTFS", 
	"RAID", 
	"ccd", 
	"jfs", 
	"Apple UFS", 
	"obsolete vinum", 
	NULL 
}; 
#define FSMAXTYPES	(sizeof(fstypenames) / sizeof(fstypenames[0]) - 1) 
#endif 
 
/* 
 * flags shared by various drives: 
 */ 
#define	D_REMOVABLE	0x01	/* removable media */ 
#define	D_ECC		0x02	/* supports ECC */ 
#define	D_BADSECT	0x04	/* supports bad sector forw. */ 
#define	D_RAMDISK	0x08	/* disk emulator */ 
#define	D_CHAIN		0x10	/* can do back-back transfers */ 
 
/* 
 * Drive data for SMD. 
 */ 
 
#define	d_smdflags	d_drivedata[0] 
#define	D_SSE		0x1	/* supports skip sectoring */ 
#define	d_mindist	d_drivedata[1] 
#define	d_maxdist	d_drivedata[2] 
#define	d_sdist		d_drivedata[3] 
 
/* 
 * Drive data for ST506. 
 */ 
#define d_precompcyl	d_drivedata[0] 
#define d_gap3		d_drivedata[1]	/* used only when formatting */ 
 
/* 
 * Drive data for SCSI. 
 */ 
#define	d_blind		d_drivedata[0] 
 
#ifndef _LOCORE 
/* 
 * Structure used to perform a format or other raw operation, 
 * returning data and/or register values.  Register identification 
 * and format are device- and driver-dependent. 
 */ 
struct format_op { 
	char	*df_buf; 
	int	df_count;	/* value-result */ 
	daddr_t	df_startblk; 
	int	df_reg[8];	/* result */ 
}; 
 
/* 
 * Structure used internally to retrieve information about a partition 
 * on a disk. 
 */ 
struct partinfo { 
	struct	disklabel *disklab; 
	struct	partition *part; 
};

Disk specific ioctls are defined in sys/dkio.h.

/* 
 * Disk-specific ioctls. 
 */ 
	/* get and set disklabel; DIOCGPART used internally */ 
#define DIOCGDINFO   _IOR('d', 101, struct disklabel) /* get */ 
#define DIOCSDINFO   _IOW('d', 102, struct disklabel) /* set */ 
#define DIOCWDINFO   _IOW('d', 103, struct disklabel) /* set, update disk */ 
#define DIOCGPART    _IOW('d', 104, struct partinfo)  /* get partition */ 
 
	/* do format operation, read or write */ 
#define DIOCRFORMAT	_IOWR('d', 105, struct format_op) 
#define DIOCWFORMAT	_IOWR('d', 106, struct format_op) 
 
#define DIOCSSTEP	_IOW('d', 107, int) /* set step rate */ 
#define DIOCSRETRIES	_IOW('d', 108, int) /* set # of retries */ 
#define DIOCKLABEL	_IOW('d', 119, int) /* keep/drop label on close? */ 
#define DIOCWLABEL	_IOW('d', 109, int) /* write en/disable label */ 
 
#define DIOCSBAD	_IOW('d', 110, struct dkbad) /* set kernel dkbad */ 
#define DIOCEJECT	_IOW('d', 112, int) /* eject removable disk */ 
#define DIOCLOCK	_IOW('d', 113, int) /* lock/unlock pack */ 
 
	/* get default label, clear label */ 
#define	DIOCGDEFLABEL	_IOR('d', 114, struct disklabel) 
#define	DIOCCLRLABEL	_IO('d', 115)
February 24, 2006 NetBSD 7.0