Manual browser: disktab(5)

Section:
Page:
DISKTAB(5) File Formats Manual DISKTAB(5)

NAME

disktabdisk description file

SYNOPSIS

#include <disktab.h>

DESCRIPTION

disktab is a simple database which describes disk geometries and disk partition characteristics. It is used to initialize the disk label on the disk. The format is described in capfile(5). Entries in disktab consist of a number of `:' separated fields. The first entry for each disk gives the names which are known for the disk, separated by `|' characters. The last name given should be a long name fully identifying the disk.

The following list indicates the normal values stored for each disk entry.

Name Type Description
ty str Type of disk (e.g. removable, winchester)
dt str Type of controller (e.g. SMD, ESDI, floppy)
ns num Number of sectors per track
nt num Number of tracks per cylinder
nc num Total number of cylinders on the disk
sc num Number of sectors per cylinder, ns*nt default
su num Number of sectors per unit, sc*nc default
se num Sector size in bytes, DEV_BSIZE default
sf bool Controller supports bad144-style bad sector forwarding
rm num Rotation speed, rpm, 3600 default
sk num Sector skew per track, default 0
cs num Sector skew per cylinder, default 0
hs num Headswitch time, usec, default 0
ts num One-cylinder seek time, usec, default 0
il num Sector interleave (n:1), 1 default
d[0-4] num Drive-type-dependent parameters
bs num Boot block size, default BBSIZE
sb num Superblock size, default SBSIZE
ba num Block size for partition `a' (bytes)
bd num Block size for partition `d' (bytes)
be num Block size for partition `e' (bytes)
bf num Block size for partition `f' (bytes)
bg num Block size for partition `g' (bytes)
bh num Block size for partition `h' (bytes)
fa num Fragment size for partition `a' (bytes)
fd num Fragment size for partition `d' (bytes)
fe num Fragment size for partition `e' (bytes)
ff num Fragment size for partition `f' (bytes)
fg num Fragment size for partition `g' (bytes)
fh num Fragment size for partition `h' (bytes)
oa num Offset of partition `a' in sectors
ob num Offset of partition `b' in sectors
oc num Offset of partition `c' in sectors
od num Offset of partition `d' in sectors
oe num Offset of partition `e' in sectors
of num Offset of partition `f' in sectors
og num Offset of partition `g' in sectors
oh num Offset of partition `h' in sectors
pa num Size of partition `a' in sectors
pb num Size of partition `b' in sectors
pc num Size of partition `c' in sectors
pd num Size of partition `d' in sectors
pe num Size of partition `e' in sectors
pf num Size of partition `f' in sectors
pg num Size of partition `g' in sectors
ph num Size of partition `h' in sectors
ta str Partition type of partition `a' (4.2BSD filesystem, swap, etc)
tb str Partition type of partition `b'
tc str Partition type of partition `c'
td str Partition type of partition `d'
te str Partition type of partition `e'
tf str Partition type of partition `f'
tg str Partition type of partition `g'
th str Partition type of partition `h'

FILES

/etc/disktab

HISTORY

The disktab description file appeared in 4.2BSD.
April 5, 2012 NetBSD 7.0