Manual browser: forward(5)
|FORWARD(5)||File Formats Manual||FORWARD(5)|
NAMEforward — mail forwarding instructions
DESCRIPTIONThe .forward file contains a list of mail addresses or programs that the user's mail should be redirected to. If the file is not present, then no mail forwarding will be done. Mail may also be forwarded as the standard input to a program by prefixing the line with the normal shell pipe symbol (|). If arguments are to be passed to the command, then the entire line should be enclosed in quotes. For security reasons, the .forward file must be owned by the user the mail is being sent to, or by root, and the user's shell must be listed in /etc/shells.
For example, if a .forward file contained the following lines:
nobody@NetBSD.org "|/usr/bin/vacation nobody"
Mail would be forwarded to <nobody@NetBSD.org> and to the program /usr/bin/vacation with the single argument nobody.
If a local user address is prefixed with a backslash character, mail is delivered directly to the user's mail spool file, bypassing further redirection.
For example, if user chris had a .forward file containing the following lines:
One copy of mail would be forwarded to chris@otherhost and another copy would be retained as mail for local user chris.
- The user's forwarding instructions.
|July 2, 1996||NetBSD 7.0|