Manual browser: dumpfs(8)
|DUMPFS(8)||System Manager's Manual||DUMPFS(8)|
NAMEdumpfs — dump file system information
|dumpfs||[-acFijmsv] filesys | device [...]|
DESCRIPTIONdumpfs prints out detailed information about the specified filesystems.
- Print details from each alternate superblock.
- Print details of each cylinder group.
- Dump a file system image from a file, not a special device.
- Print details of each allocated inode.
- Print details of the WAPBL journal.
- Print details of the cylinder group summary.
- Print details of the superblock.
- Be even more verbose.
If none of -a, -c, -i, -j, -m, or -s are given, then dumpfs defaults to -cmsv.
dumpfs is useful mostly for finding out certain file system information such as the file system block size, minimum free space percentage, and the file system level that can be upgraded with the -c option of fsck_ffs(8). All of this information is output by dumpfs -s.
HISTORYThe dumpfs command appeared in 4.2BSD. The -a, -c, -i, -m, and -s options, and the inode dump were added for NetBSD 2.0. The -j, option was added for NetBSD 6.0.
|February 27, 2010||NetBSD 7.0|